Как объединить две таблицы Excel в одну

Как часто, работая с данными, вам удается уместить всю необходимую для анализа информацию в одну таблицу? Скорее всего, никогда.

Чаще всего, нужные нам данные находятся в разных файлах и мы сталкиваемся с необходимостью сопоставить или объединить их из нескольких таблиц в одну.

В этой статье мы рассмотрим наиболее эффективные способы как это сделать.

Как объединить две таблицы Excel с помощью функции ВПР

Если вы хотите сопоставить две таблицы по данным из одного столбца, то тут лучше всего подойдет функция ВПР.

Представим, у нас есть две таблицы. В основной таблице у нас есть данные с наименованиями товаров, продавцов и количестве продаж, а во второй с ценами на эти товары. Мы хотим подставить данные с ценами на товары в таблицу с данными о продажах и посчитать выручку на каждого из продавцов.

Как объединить две таблицы Excel в одну

Для этого в ячейку D2 вставим формулу с функцией ВПР:

=ВПР(B2;$G$2:$H$4;2;0)

Где:

  • B2 – ячейка с названием товара, которое мы ищем в таблице с ценами;
  • $G$2:$H$4 – диапазон ячеек таблицы с наименованием товаров и ценами. В столбце G содержатся названия товаров, по которым функция осуществляет поиск. В столбце H отражены цены, которые функция ВПР будет подставлять в нашу таблицу. Диапазон ячеек включает в себя значки $, с их помощью диапазон зафиксирован и не будет изменяться при протягивании формулы по другим ячейкам.
  • 2 – номер столбца в диапазоне данных с ценами на товары, которые мы хотим подставить в нашу таблицу.
  • 0 – точность совпадения данных. Ставим “0”, так как нам необходимо точное совпадение.

Протянем полученную формулу на все строки столбца и получим таблицу с расчетом выручки по каждому товару, для каждого продавца.

Как объединить две таблицы Excel в одну

Оцени запись
Написать комментарий

Подпишись на наш Telegram канал

с лайфхаками в Excel

blank