Функция AND (И) в Excel. Как использовать?

Функция AND (И) в Excel используется для сравнения нескольких условий.

Что возвращает функция

Возвращает TRUE если значение или условие, при сравнении, соответствует критериям заданным в функции, или FALSE, в случае, если условие не соответствует критериям.

Синтаксис

=AND(logical1, [logical2],…) – английская версия

(логическое_значение1;[логическое_значение2];…)
– русская версия

Аргументы функции

  • logical1 (логическое_значение1) – первое условие, которое вы хотите оценить с помощью функции;
  • [logical2] ([логическое_значение2]) (не обязательно) – второе условие, которое вы хотите оценить с помощью функции.

Дополнительная информация

  • Функция может быть использована совместно с другими формулами;
  • Например, с помощью функции IF (ЕСЛИ) вы можете проверить условие, а затем указать значение, когда оно TRUE, и значение, когда оно равно FALSE. Использование функции AND (И) вместе с функцией  IF (ЕСЛИ) позволяет тестировать несколько условий за один раз;
    Например, если вы хотите проверить значение в ячейке A1 на предмет того, больше оно чем “0” и вместе с тем, меньше ли оно чем “100”, вы можете использовать следующую формулу:

=IF(AND(A1>0,A1<100),”Approve”,”Reject”) – английская версия

=ЕСЛИ(И(A1>0;A1<100);”Одобрить”;”Против”) – русская версия

  • Аргументы функции должны быть логически вычислимы по принципу (TRUE/FALSE);
  • Ячейки с пустыми или текстовыми значениями игнорируются функцией;
  • Если в качестве аргументов функции не указаны логически вычислимые данные, то функция выдаст ошибку #VALUE!;
  • Одновременно вы можете тестировать до 255 условий в рамках одного использования функции.

Примеры использования функции AND (И, ИЛИ) в Excel

Функция AND (И) в Excel. Примеры использования

comments powered by HyperComments
Понравилась статья? Поделиться с друзьями: