Топ-100

Как посчитать среднее значение в Excel

В этой статье мы разберем как посчитать среднее значение в Excel с числами, текстом, пустыми ячейками, а также по заданным критериям.

Как посчитать среднее значение чисел в Excel

Найти среднее арифметическое чисел в Excel можно с помощью функции СРЗНАЧ.

Синтаксис СРЗНАЧ

=СРЗНАЧ(число1;[число2];…) – русская версия

Аргументы СРЗНАЧ

  • число1 – первое число или диапазон чисел, для расчета среднего арифметического;
  • число2 (Опционально) – второе число или диапазон чисел для расчета среднего арифметического. Максимальное количество аргументов функции – 255.

Для расчета проделайте следующие шаги:

  • Выделите любую ячейку;
  • Напишите в ней формулу =СРЗНАЧ(
  • Выделите диапазон ячеек, для которого требуется сделать расчет;
  • Нажмите клавишу “Enter” на клавиатуре

Как посчитать среднее значение в Excel

Функция рассчитает среднее значение в указанном диапазоне среди тех ячеек, в которых есть числа.

Как найти среднее значение с учетом текста

Если в диапазоне данных есть текст, то рекомендую использовать функцию СРЗНАЧА. Она работает как функция СРЗНАЧ. Отличие в том, что она учитывает пустые ячейки, текст и значения ЛОЖЬ/ИСТИНА.

Если в диапазоне данных есть пустые строки или текст, то функция воспринимает их как “ноль”. Если среди данных есть логические выражения ЛОЖЬ или ИСТИНА, то ЛОЖЬ функция воспринимает как “ноль”, а ИСТИНА как “1”.

Как найти среднее арифметическое по условию

Для расчета среднего по условию или критерию используется функция СРЗНАЧЕСЛИ. Например, представим что у нас есть данные по продажам товаров:

Функция СРЗНАЧЕСЛИ в Excel

Наша задача вычислить среднее значение продаж ручек. Для этого проделаем следующие шаги:

  • В ячейке A13 напишем название товара “Ручки”;
  • В ячейке B13 введем формулу:

=СРЗНАЧЕСЛИ(A2:A10;A13;B2:B10)

Диапазон ячеек “А2:A10” сообщает функции список товаров, в котором надо найти текс “Ручки”.  Аргумент “A13” – это ссылка на ячейку с текстом “Ручки”, которые мы будем искать среди всего списка товаров. Диапазон ячеек “B2:B10” это диапазон с данными продаж товаров, среди которых функция найдет “Ручки” и вычислит среднее значение.

Среднее значение в Excel по условию

 

Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: