Функция OR (ИЛИ) в Excel. Как использовать?

Функция OR (ИЛИ) в Excel используется для сравнения двух условий.

Что возвращает функция

Возвращает логическое значение TRUE (Истина), при выполнении условий сравнения в функции и отображает FALSE (Ложь), если условия функции не совпадают.

Синтаксис

=OR(logical1, [logical2],…) – английская версия

=ИЛИ(логическое_значение1;[логическое значение2];…) – русская версия

Аргументы функции

  • logical1 (логическое_значение1) – первое условие которое оценивает функция по логике TRUE или FALSE;
  • [logical2] ([логическое значение2]) – (не обязательно) это второе условие которое вы можете оценить с помощью функции по логике TRUE или FALSE.

Дополнительная информация

  • Функция OR (ИЛИ) может использоваться с другими формулами.

Например, в функции IF (ЕСЛИ) вы можете оценить условие и затем присвоить значение, когда данные отвечают условиям логики TRUE или FALSE. Используя функцию вместе с IF (ЕСЛИ), вы можете тестировать несколько условий оценки значений за раз.

Например, если вы хотите проверить значение в ячейке А1 по условию: “Если значение больше “0” или меньше “100” то… “ – вы можете использовать следующую формулу:

=IF(OR(A1>100,A1<0),”Верно”,”Неверно”) – английская версия

=ЕСЛИ(ИЛИ(A1>100;A1<0);”Верно”;”Неверно”) – русская версия

  • Аргументы функции должны быть логически вычислимы по принципу TRUE или FALSE;
  • Текст и пустые ячейки игнорируются функцией;
  • Если вы используете функцию с не логически вычисляемыми значениями – она выдаст ошибку;
  • Вы можете тестировать максимум 255 условий в одной формуле.

Примеры использования функции OR (ИЛИ) в Excel

Пример 1. Используем аргументы TRUE и FALSE в функции OR (ИЛИ)

Функция OR (ИЛИ) в Excel

Вы можете использовать TRUE/FALSE в качестве аргументов. Если любой из них соответствует условию TRUE, функция выдаст результат TRUE. Если оба аргумента функции соответствуют условию FALSE, функция выдаст результат FALSE.

Она может использовать аргументы TRUE и FALSE в кавычках.

Пример 2. Используем ссылки на ячейки, содержащих TRUE/FALSE

Функция OR (ИЛИ) в Excel

Вы можете использовать ссылки на ячейки со значениями TRUE или FALSE. Если любое значение из ссылок соответствует условиям TRUE, функция выдаст TRUE.

Пример 3. Используем условия с функцией OR (ИЛИ)

Функция OR (ИЛИ) в Excel

Вы можете проверять условия с помощью функции OR (ИЛИ). Если любое из условий соответствует TRUE, функция выдаст результат TRUE.

Пример 4. Используем числовые значения с функцией OR (ИЛИ)

Функция OR (ИЛИ) в Excel

Число “0” считается FALSE в Excel по умолчанию. Любое число, выше “0”, считается TRUE (оно может быть быть положительным, отрицательным или десятичным числом).

Пример 5. Используем функцию OR (ИЛИ) с другими функциями

Вы можете использовать функцию OR (ИЛИ) с другими функциями для того, чтобы оценить несколько условий.

На примере ниже показано, как использовать функцию вместе с IF (ЕСЛИ):

Функция OR (ИЛИ) в Excel

На примере выше, мы дополнительно используем функцию IF (ЕСЛИ) для того, чтобы проверить несколько условий. Формула проверяет значение ячеек А2 и A3. Если в одной из них значение более чем “70”, то формула выдаст “TRUE”.

comments powered by HyperComments
Понравилась статья? Поделиться с друзьями: